当前位置: 网站首页 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

触底主力,和谐源码分享,副图(通达信公式)

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

{触底主力}

ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZSHTL:=SHCM/(ZLCM+SHCM)*100;
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZCMZL:=MA(ZLCM+SHCM,13);
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);
ZSHJJ:=EMA(ZSHTL,89);
ZZLJJ:=EMA(ZZLKP,89);
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);
STICKLINE(C>0,ZZLKP,0,3,0),COLORBLUE;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,3,0),COLORFF00FF;
{★底部提示:副}80,POINTDOT;   
60,LINETHICK2,COLORRED;
50,LINETHICK1,COLORYELLOW;
40,LINETHICK2,COLORRED;
20,POINTDOT;
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
AA:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND C>O;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
STICKLINE(VAR9>VARA,VAR9,VARA,6,0),COLORRED;
STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLORFFCC66;
RR8:=MA(CLOSE,27);
RR9:=(CLOSE-RR8)/RR8*100;
RRA:=MA(RR9,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
黄金坑:=IF(RRD,-35,0),COLORYELLOW,LINETHICK3;
VARO1:=MA(CLOSE,27);
VARO2:=(CLOSE-VARO1)/VARO1*100;
VARO3:=MA(VARO2,2);
VARO4:=BARSLAST(CROSS(-10,VARO3)=1);
VARO5:=VARO3<-10 AND VARO4>3;
贪嘴乐:= IF(VARO3>REF(VARO3,1) AND VARO5 AND VARO3<-15,60,0),LINETHICK3,LINESTICK,COLORFFA2AF;
VAR1Z:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2Z:=SUMBARS(VOL,CAPITAL);
VAR3Z:=HHV(VAR1Z,VAR2Z);
VAR4Z:=LLV(VAR1Z,VAR2Z);
VAR5Z:=(2*VAR1Z-VAR4Z-REF(VAR4Z,1))/(VAR3Z-VAR4Z);
VAR6Z:=(VAR1Z-VAR4Z)/(VAR3Z-VAR4Z);
VAR7Z:=IF(VAR1Z<=VAR4Z,VAR5Z*60,VAR6Z*60);
VAR8Z:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9Z:=EMA(VAR8Z,7);
VARAZ:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARBZ:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
XA_1:=(CLOSE-LLV(CLOSE,10))/(HHV(CLOSE,10)-LLV(CLOSE,10));
强庄起爆:=CROSS(XA_1,0.05)*3 AND FILTER(CLOSE/REF(CLOSE,1)>1.048 AND C=H 
AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12)),28) 
AND NOT(DYNAINFO(4)=0);
STICKLINE(强庄起爆,0,1,2,0),COLORYELLOW;
DRAWICON(强庄起爆,0.9,26);
DRAWTEXT(强庄起爆,0.9,' 强庄起爆'),COLORYELLOW;
{吸筹}
A1P:=REF(CLOSE,2);
A2P:=SMA(MAX(CLOSE-A1P,0),7,1)/SMA(ABS(CLOSE-A1P),7,1)*100;
A4P:=REF(LOW,1);
A5P:=SMA(ABS(LOW-A4P),3,1)/SMA(MAX(LOW-A4P,0),3,1)*100;
A6P:=EMA(IF(CLOSE*1.3,A5P*10,A5P/10),3);
A7P:=LLV(LOW,29);
A8P:=HHV(A6P,37);
A9P:=IF(MA(CLOSE,90),1,0);
A10P:=EMA(IF(LOW<=A7P,(A6P+A8P*2)/2,0),3)/1688*A9P;
A11P:=IF(A10P>100,100,A10P);
STICKLINE(A11P,0,A11P,4,1),COLOR666666;
VARF:=TROUGHBARS(3,15,1)<3.15 AND REF(TROUGHBARS(3,13,1)<3.15,1) AND REF(TROUGHBARS(3,11,1)<3.15,2);
多空股神:=(EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,25))/MA((2*CLOSE+HIGH+LOW)/4,25)*100,3))*1.65,LINETHICK3,COLORWHITE;
STICKLINE(FILTER(VARF=1,5) AND 多空股神<-10,33,0,6.0,0),COLORF00FF0;
STICKLINE(FILTER(VARF=1,5),30,0,3.5,0),COLORYELLOW;
VARFC: TROUGHBARS(3,12,1)<3 AND REF(TROUGHBARS(3,12,1)<3,1) AND REF(TROUGHBARS(3,12,1)<3,2);
DRAWICON(FILTER(VARFC=1,3),40,1),COLORFFFF00;
STICKLINE(FILTER(VARFC=1,5),36,0,2.25,0),COLORRED;
STICKLINE(FILTER(VARFC=1,5),35,0,0.35,1),COLORRED,COLORYELLOW;
触底:DRAWTEXT(FILTER(VARFC=1,3),37,'触底(背离有效)'),COLORYELLOW;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
XG:=(FILTER((VAR4AA>90),45)),COLORYELLOW;
STICKLINE(XG,20,0,4,0),COLOR000099;
STICKLINE(XG,50,0,2,0),COLOR0000BB;
STICKLINE(XG,60,0,1,0),COLOR0000DD;
STICKLINE(XG,60,0,0.9,0),COLOR0000FF;
DRAWTEXT(XG>0,60,'波段多空起暴'),COLOR00C5FF;
DRAWTEXT_FIX(1,0,100,0,'★出现红柱波段起爆后市看涨,背离共振粘合有效!!!'),COLORYELLOW;
WWW58188COM:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
DIF:=(EMA(C,12)-EMA(C,26));
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
MJBT:=EXIST((CROSS(DIF,DEA) AND DIF>0) OR CROSS(DIF,0),5) ;
MVOL5:=MA(V,5);
MVOL10:=MA(V,10);
MVOL20:=MA(V,20);
量托:=MVOL5>=MVOL20 AND CROSS(MVOL10,MVOL20) AND REF(MVOL10,1)<REF(MVOL20,1);
VJBT:=EXIST(CROSS(MVOL5,MVOL10) OR 量托,5);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA60:=MA(C,60);
MA120:=MA(C,120);
T1:=BARSLAST(REF(LONGCROSS(MA60,MA120,55),1));
JJC:=CROSS(MA5,MA10);
SJBT:FILTER(MJBT AND JJC AND VJBT,5);
DRAWBAND(0,RGB(0,0,0),SJBT*18,RGB(218,218,18));
DRAWTEXT(SJBT,16,'游资多空启动'),COLOR0078FF;
年选股:SUM(SJBT,250),NODRAW;
利润:=REF(SJBT,30) AND HHV(H,30)>=REF(C,30)*1.10;
成功:SUM(利润,250),NODRAW;
成功率%:成功/年选股*100,NODRAW;    
散户能量: SMA((HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20))*100,2,1),COLORGREEN,LINETHICK2;
20,POINTDOT,COLORF00FF0;
50,POINTDOT,COLORGREEN;
80,POINTDOT,COLORWHITE;

上一篇:趋势单线,黄金柱建仓,和谐源码分享,主图(通达信公式)

下一篇:没有了