当前位置: 网站首页 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码精选:蜡烛图全景图,操盘铁律,筹码红绿柱,筹码分布

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、蜡烛图全景图

年涨幅:(DYNAINFO(7)-O#YEAR)/O#YEAR*100,NODRAW;
季涨幅:(DYNAINFO(7)-O#SEASON)/O#SEASON*100,NODRAW;
月涨幅:(DYNAINFO(7)-O#MONTH)/O#MONTH*100,NODRAW;
周涨幅:(DYNAINFO(7)-O#WEEK)/O#WEEK*100,NODRAW,COLORCYAN;
 
 
年毛利:(HHV(H,YEAR)-LLV(L,YEAR))/LLV(L,YEAR)*100*0.44,NODRAW,COLORRED;
月毛利:(HHV(H,MONTH)-LLV(L,MONTH))/LLV(L,MONTH)*100*0.44,NODRAW,COLORGREEN;
周毛利:(HHV(H,WEEKDAY)-LLV(L,WEEKDAY))/LLV(L,WEEKDAY)*100*0.44,NODRAW;
日毛利:(HHV(H,1)-LLV(L,1))/LLV(L,1)*100*0.44,NODRAW,COLORYELLOW;
 
 
{年涨跌}
年O:=O#YEAR,NODRAW;年C:=C#YEAR,NODRAW;
年H:=H#YEAR,NODRAW;年L:=L#YEAR,NODRAW;
 
{STICKLINE(年C>=年O,年O,年C,5,0),COLOR34567F;{年涨}
{STICKLINE(年C<年O,年O,年C,5,0),COLORLICYAN;{年跌}
 
 
STICKLINE(年C>=年O,年L,年H,5,0),COLORFF3EBF;{年涨}
STICKLINE(年C<=年O,年L,年H,5,0),COLORFF7648;{年跌}
STICKLINE(年C>=年O,年O,年C,5,0),COLOR00008B;{年涨}
STICKLINE(年C<年O,年O,年C,5,0),COLORAA0000;{年跌};
 
 
{季涨跌}
季O:=O#SEASON,NODRAW;季C:=C#SEASON,NODRAW;
季H:=H#SEASON,NODRAW;季L:=L#SEASON,NODRAW;
 
{STICKLINE(季C>=季O,季C,季O,5,0),COLOR996998;{季度涨}
{STICKLINE(季C<季O,季C,季O,5,0),COLORGRAY;{季度跌}
 
 
STICKLINE(季C>=季O,季H,季L,5,0),COLORLIRED;{季度涨}
STICKLINE(季C<季O,季H,季L,5,0),COLORLIGREEN;{季度跌}
STICKLINE(季C>=季O,季C,季O,5,0),COLOR996998;{季度涨}
STICKLINE(季C<季O,季C,季O,5,0),COLORGRAY;{季度跌};
 
 
{月涨跌}
月O:=O#MONTH,NODRAW;月H:=H#MONTH,NODRAW;
月L:=L#MONTH,NODRAW;月C:=C#MONTH,NODRAW;
 
STICKLINE(月C>=月O,月H,月L,5,1),COLORYELLOW;{月涨}
STICKLINE(月C<月O,月H,月L,5,1),COLORWHITE;{月跌}
STICKLINE(月C>=月O,月C,月O,5,1),COLORLIRED;{月涨}
STICKLINE(月C<月O,月C,月O,5,1),COLORGREEN;{月跌}
 
{周涨跌}
周O:=O#WEEK,NODRAW;周H:=H#WEEK,NODRAW;
周L:=L#WEEK,NODRAW;周C:=C#WEEK,NODRAW;
STICKLINE(WEEKDAY=3 AND 周C>周O,周H,周L,1,0),COLORCC3299;
STICKLINE(WEEKDAY=3 AND 周C<周O,周H,周L,1,0),COLORBLUE;
STICKLINE(周C>=周O,周O,周C,5,0),COLORCC3299;{周涨}
STICKLINE(周C<周O,周O,周C,5,0),COLORBLUE;{周跌}
 
 
 
{画K线} 
 
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
 



2、操盘铁律

操盘铁律,买卖主图,有卖点和买点提示,最强趋势主图

 DRAWTEXT_FIX(1,0.00,0.00,0,'【★★ WWW.58188.COM★★】'),COLORFF00FF;

DRAWTEXT_FIX(1,0.00,0.05,0,'【★★操                       盘                       铁                       律★★】'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.10,0,'【★★操盘原则:1、早盘高开不追;2、尾盘跳水不买★★】'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.15,0,'【★★短线盈亏:3、百分之十止盈;4、百分之五止损★★】'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.20,0,'【★★中长盈亏:5、中线二十个点;6、长线三十点上★★】'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.25,0,'【★★消除干扰:7、利好优先关注;8、利空静观其变★★】'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.30,0,'【★★买卖准则:9、严格遵守盈亏;0、牢记操作铁律★★】'),COLOR00FFFF;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,' ');
DRAWTEXT_FIX(ISLASTBAR,0.00,0.99,0,STRCAT(Z4,GNBLOCK)),COLORGREEN;
DA:(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
DB:(20*DA+19*REF(DA,1)+18*REF(DA,2)
+17*REF(DA,3)+16*REF(DA,4)+15*REF(DA,5)+14*REF(DA,6)+13*REF(DA,7)
+12*REF(DA,8)+11*REF(DA,9)+10*REF(DA,10)+9*REF(DA,11)
+8*REF(DA,12)+7*REF(DA,13)+6*REF(DA,14)+5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)
+2*REF(DA,18)+REF(DA,20))/210,COLORF0F000;DC:MA(DB,5),COLORYELLOW,LINETHICK1;
STICKLINE(DC>DB , DC,DB ,2.5,0),COLORRED,LINETHICK2;
STICKLINE(DB>DC,DC,DB,2.5,0),COLORGREEN,LINETHICK2;
买点:=CROSS(DB,DC) AND DB>DC;
DRAWTEXT(买点,DB*0.98,'买点'),COLORYELLOW;
卖点:=CROSS(DC,DB) AND DC>DB;
DRAWTEXT(卖点,DC*1.02,'卖点'),COLORYELLOW;
{股民学院 www.58188.com 整理}



3、筹码红绿柱

 {筹码红绿柱}

五十成本集中:=(COST(75)-COST(25))/(COST(75)+COST(25))*100;
成本价1:=COST(五十成本集中),COLORGREEN;
五十成本集中1:=100-五十成本集中;
成本价2:=COST(五十成本集中1),COLORBLUE;
单峰密集价:成本价2/成本价1-1,STICK;
红:=REF(单峰密集价,1)<单峰密集价 AND 成本价2>REF(成本价2,1) ;
绿:=REF(单峰密集价,1)>单峰密集价;
主力筹码:=单峰密集价<=0.25;
底部:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
底部成本价:=COST(底部),COLORYELLOW;
顶部:=100-底部;
顶部成本价:=COST(顶部),COLORGREEN;
均值:=(底部+顶部)/2;
均值成本:=COST(均值),COLORLICYAN,DOTLINE;
 STICKLINE(红,单峰密集价,0,2.8,0),COLOR000055;
 STICKLINE(红,单峰密集价,0,2,0),COLOR000088;
 STICKLINE(红,单峰密集价,0,1.5,0),COLOR0000AA;
 STICKLINE(红,单峰密集价,0,1,0),COLOR0000CC;
 STICKLINE(红,单峰密集价,0,0.5,0),COLOR0000EE;
 STICKLINE(红,单峰密集价,0,0,0),COLORFFFFFF;
底:=REF(单峰密集价,2)<REF(单峰密集价,1) AND 单峰密集价<REF(单峰密集价,1) AND 均值成本<REF(均值成本,1);
 STICKLINE(底,单峰密集价,0,0,0),COLORGREEN;
 STICKLINE(底,单峰密集价,0,2.8,0),COLOR009900;
 STICKLINE(底,单峰密集价,0,2,0),COLOR00BB00;
 STICKLINE(底,单峰密集价,0,1.5,0),COLOR00DD00;
 STICKLINE(底,单峰密集价,0,0.5,0),COLOR00FF00;
顶:=REF(单峰密集价,2)<REF(单峰密集价,1) AND 单峰密集价<REF(单峰密集价,1) AND 均值成本>REF(均值成本,1);
 STICKLINE(顶,单峰密集价,0,2,0),COLORYELLOW;



4、筹码分布,筹码类公式

 
{筹码分布}
当前获利:=WINNER(C)*100,COLORAAAAFF,STICK,NODRAW;
赚10%:WINNER(C/1.1)*100,COLORRED,NODRAW;
赚20%:WINNER(C/1.2)*100,COLORYELLOW,NODRAW;
赚30%:WINNER(C/1.3)*100,COLORMAGENTA,NODRAW;
R10:=当前获利-赚10%;
STICKLINE(1,当前获利,赚10%,-1,0),COLORRED,NODRAW;
STICKLINE(1,赚10%,赚20%,-1,0)COLOR0000CC;
STICKLINE(1,赚20%,赚30%,-1,0),COLOR00FFFF;
STICKLINE(1,赚30%,0,-1,0),COLORFF00FF;
 
亏10%:(1-WINNER(C/0.9))*100,COLORWHITE,NODRAW;
亏20%:(1-WINNER(C/0.8))*100,COLORGREEN,NODRAW;
亏30%:(1-WINNER(C/0.7))*100,COLORCYAN,NODRAW;
S10:=100-亏10%-当前获利;
STICKLINE(C>0,100-亏10%,100-亏20%,-1,0),COLORCYAN;
STICKLINE(C>0,100-亏20%,100-亏30%,-1,0),COLORGREEN;
STICKLINE(C>0,100-亏30%,100,-1,0),COLORWHITE;
当前价获利盘%:当前获利,COLORYELLOW,LINETHICK1,NODRAW;
当日获利套牢:当前获利-REF(当前获利,1),NODRAW;
 
近5日获利比例:LWINNER(5,C)*100,COLORRED,NODRAW;
浮筹:R10+S10,DOTLINE,COLORWHITE,LINETHICK2;
老筹:PPART(30)*100,COLORLIRED,LINETHICK3;
 
{区间集中度:(WINNER(C*(1+0.05))-WINNER(C*(1-0.05)))*100,NODRAW;
40,DOTLINE,COLORLIMAGENTA;
70,DOTLINE;
12.5,CIRCLEDOT,COLORWHITE;}
{SAR}
{持币:IF(SAR(10,2,20)>=H,100,DRAWNULL),CIRCLEDOT,COLORWHITE,LINETHICK4;
持股:IF(SAR(10,2,20)<=L,100,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK4;};

上一篇:通达信精选下载组合公式21个

下一篇:通达信源码精选:筹码分散研究,古丰风云,XJP新极,操盘学实训版